Corrupt attachments
Incident Report for CloudMailin Status
Resolved
This incident has been resolved.
Posted Feb 28, 2024 - 12:19 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 27, 2024 - 21:40 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 27, 2024 - 18:22 UTC
Monitoring
At 12:10 UTC we deployed a change which attempted to fix an encoding problem for a small number of customers. This change appears to have resulted in attachments incorrectly being transformed into utf-8 instead of remaining in the binary character set. This change resulted in the corruption of these files as they were persisted to attachment storage.

Unfortunately this has resulted in emails received in this time period having corrupt files. We're deeply sorry for this mistake on our part. The change has been rolled back and should no longer be causing an issue and we are continuing to monitor the situation.

Steve
- Founder, CloudMailin.com
Posted Feb 27, 2024 - 16:31 UTC
Identified
A deployment at 12:10 UTC included code which attempted to resolve a long standing issue with encoding for a small subset of users. This fix unintentionally broke the character encoding of attachments being processed by CloudMailin and has resulted in the corruption of a number of files. We'll continue to investigate.

The change has been rolled back
Posted Feb 27, 2024 - 16:18 UTC
Investigating
We're currently investigating reports of corrupted files within attachment storage.
Posted Feb 27, 2024 - 16:00 UTC
This incident affected: Inbound Message Delivery.