Issues accessing CloudMailin.com
Incident Report for CloudMailin Status
Resolved
Things appear to be resolved. Unfortunately an issue with our upstream provider (Heroku - https://status.heroku.com/incidents/2402) was the root cause.

Although not every customer was affected, unfortunately this incident caused issues with message delivery for some customers. Any messages that were not be received will have been asked to retry later, most will likely have already done so.

Our next priority will be investigating our options to mitigate against issues like this in future.
Posted Feb 24, 2022 - 17:37 UTC
Monitoring
Things appear to be stabilising. We're continuing to monitor and investigate
Posted Feb 24, 2022 - 17:12 UTC
Update
Things appear to have been resolved. We're continuing to monitor the situation and investigate.
Posted Feb 24, 2022 - 17:10 UTC
Identified
Our upstream provider is having issues resulting in a knock on affect to some parts of our service. More details from the provider can be found: https://status.heroku.com/incidents/2402.

In the meantime we're working on mitigating the impact for our customers also.
Posted Feb 24, 2022 - 16:55 UTC
Investigating
We are currently investigating this issue.
Posted Feb 24, 2022 - 16:45 UTC
This incident affected: Inbound Message Delivery, Outbound Message Delivery, and Management Website.